Stage 2, Complete

Whew again. Stage 2 of the migration is now complete. You’re looking at the new (and, one hopes, improved) Planned Obsolescence. Here’s what’s happened since the last update:

  • Installed ExpressionEngine in new subdomain on new server.
  • Futzed around with ExpressionEngine, trying to figure out how it works.
  • Built new site in new subdomain.
  • Imported old entries into new site.
  • Tinkered with CSS.
  • Went through all old entries (!) re-coding broken internal links.
  • Tinkered more with CSS.
  • Built new graphic, above.
  • Fixed CSS where new graphic broke it.
  • Ported the whole kit-n-kaboodle over to main domain.
  • Created redirect for old “po” subdirectory.

And here we are!

Do note that my primary URL has changed: since my previous hosting provider wouldn’t allow true subdomains (such as subdomain.plannedobsolescence.net), I had set Planned Obsolescence up in a subdirectory, anticipating the possibility of further site additions. Now that my good friends at DreamHost have granted me way more subdomains than I’ll ever use, I’m able to put this page right up top, where it oughta be. Please update your links and blogrolls accordingly.

Any comments or thoughts would be appreciated — and particularly any notes about broken spots. I know that things are a little wonky in IE5/Mac, but frankly, if you’re on a Mac and still using IE, well…

15 thoughts on “Stage 2, Complete

  1. Should have noted, of course, that one of the effects of both the changed file-naming system and the changed top-level URI is that many of your links to me will now be broken. I believe that my redirect should flip any requests for old pages around to the main page here, though. I think.

  2. Wow, this is quite an overhaul! I thought that I had wandered into the wrong building. You’re brave, moving servers and changing programs at the same time.

    I am feeling more cautious about leaving MT; I’ll see how things go for all you guinea pigs.

    Though this DOES look nice …

  3. Thanks!

    Okay, I’ve figured out I was wrong about old archive links; they don’t redirect to the new main page; instead, you get the usual 404. This may be a massive pain, given that I’ve moved to a new (1) server, (2) URL, (3) blogging engine, and (4) file naming convention, in one fell swoop. I know Liz dealt with this problem when she migrated and changed naming systems, but that was all within MT…

    I’m off to go see if I can come up with some workaround. Any advice here would be enormously appreciated.

  4. Ergh. I’ve got no Windows machines around to check that out on. Does the entry fully overlap the banner, or just at the bottom?

  5. 1) What’s the difference between “location” and “URL”??

    2) Your old RSS feed (http://www.plannedobsolescence.net/index.xml) is broken. Maybe add a redirect from old to new for people who have you in the aggregator and don’t realize you’re posting again? (That’s what happened to me; on a whim, I checked the site and realized that I wasn’t getting the posts. No error message was generated by Bloglines.)

    3) On first page load, the banner overlaps the recent comments in the side bar. On subsequent page loads, it doesn’t. There are some HTML validation errors on the page (mostly related to ul/li missing tag issues, it looks like; you can see them here), and one error in your CSS.

  6. You could probably create an .htaccess file with a series of redirect statements, similar to what I did when I changed my archive naming conventions and switched servers.

    It would require you to create a new MT template for the .htaccess file, with something along these lines:



    Redirect permanent < $MTEntryLink$> http://www.plannedobsolescence.net/index.php?/weblog/< $MTEntryTitle dirify='1'$>/”

    (If you no longer have access to MT, that will be a problem. It might be possible to do this with a fancy php command to retrieve the info from the database, but that would require a real programmer đŸ™‚

  7. Hi, Liz. I’m puzzled by your first question — I can’t quite see what you’re referring to. Can you elaborate?

    On the RSS feed — I attempted to set up a redirect, and got a series of error messages therefrom. So I gave up. But I’ll try again.

    Thanks too for the info on the validation/css errors. As to the overlapping banner, this sounds like a variant on the problem that Matt had on Windows/Mozilla and which I’ve also seen intermittently on my Mac/Safari. Reloading always fixes it, but I’m alarmed and puzzled that it’s happening in the first place. Any thoughts on the whys and wherefores would be appreciated.

  8. In the comments form, there are places for name, email “Location:” and ”

    Validation errors could easily be causing the erratic rendering behavior. FWIW, I’m getting it in Mac/Mozilla.

    Instead of a redirect on the index.xml, you could edit that file (and index.rdf, if you had one) by hand to load the new feed instead.

  9. Aha! I get it now. As long as I’m logged into EE, I don’t see the full comment-form (EE is designed so that a blog can have “members” who can log in and comment without repeatedly providing their info; I’m at least temporarily operating without that feature). “Location” is indeed weird — why would I care “where” you are? I’ll get rid of that.

    As to the email issue — my understanding was that that was supposed to be disabled. I’ll work on that.

    Validation errors have now been corrected; we’ll see if the rendering problem persists.

    And I’ll see about recoding the xml/rdf feeds. Thanks!

  10. Okay — news feeds should be redirecting now.

    Here’s another question, though: the css template I began with uses lists as a formatting technique all over the place, and as I don’t want bullets everywhere, I’ve got separate styles defined for ul in various divs (so #sidebar ul and #rightbar ul are both set to list-style: none, while regular old ul is set to list-style: square). But what seems to be happening is that whichever ul style loads last rules all the lists on the page — bullets are either on or off. Anybody have a trick for making bullets appear here but not there?

Leave a Reply

Your email address will not be published. Required fields are marked *